Issues receiving authentication code emails

Incident Report for Rivo

Postmortem

What happened?

On February 14, 2025 at approximately 1:30pm PST, a Shopify update introduced an unexpected issue in shops_event_listener.js, which affected how CustomEvent was handled. This impacted composed events, causing disruptions for some Shadow DOM-based themes, leading to login errors for some customers.

As a result, a small number of users may have seen the message: "An error occurred during login, please try again." This issue affected a small percentage of authentication emails, causing them to be sent incorrectly as 0. This Shopify update would have also introduced unexpected issues that may have affected the way that thousands of themes that use shadow DOM with composed events functioned.

To ensure stability, we deployed a hotfix as soon as the issue was identified on February 14th at 11:55pm as Shopify worked on their resolution, which was deployed on the morning of February 15th 2025.

What’s Next?

Now that everything is back to normal, we’ve taken extra steps to improve proactive monitoring and system resilience to catch similar issues from external providers faster in the future. Thanks for your patience—and we’re sorry for any disruption here.

Posted Feb 15, 2025 - 14:17 PST

Resolved

We resolved authentication code sending and emails should be smoothly sending for everyone once again. Thanks for your patience!
Posted Feb 14, 2025 - 14:39 PST

Monitoring

We've switched to a fallback service, monitoring sending services for stability.
Posted Feb 14, 2025 - 14:29 PST

Identified

We've identified there was a delay in in authentication codes from our external email provider. There was approximately a 15 minute delay in sending codes between 1:57pm - 2:10pm PST. Email sending has resumed after a minor disruption.
Posted Feb 14, 2025 - 14:24 PST

Investigating

We're currently investigating an issue with delay in sending authentication code emails from a third party email provider. We're sorry for the disruption.
Posted Feb 14, 2025 - 14:16 PST